java版本不匹配解决办法

问题描述:eclipse加载新的项目后报一个错误,具体描述如下:

Description Resource PathLocation 

Type Java compiler level does notmatch the version of the installed Java project facet.webattemp 

Unknown FacetedProject Problem (Java Version Mismatch)

问题分析:

java版本不匹配:Facted Project 中的Java 版本设定与项目的Java 版本设定不一致。

问题解决:

在当前项目上点右键,属性–Project Facets中,配置编译版本与java compiler的版本一致。

1、选中项目后按下alt+enter组合键或者右键Project | Properties | Java Compiler(type filter text输入compiler可快速定位),如下图所示:

2、修改Project Facets的Java值,使之和Compiler compliance level相同:打开方式参考1,如下图:

总结:

       刚开始用的是eclipse比较老的一个版本,常用的文件定位的插件装上就是识别不出来,换了一个高版本的eclipse加载项目后就报出上面的错误,因为是第一次见到这个错误,以为是用的这个项目不支持高版本的eclipse呢,头说不行就用那个老版本得了,不要在这个上浪费时间,可是提高班培养出来的习惯,这样感觉就是不爽,还是想查一下再说,上网一查,这样的问题很多,当然很快就找到了解决的办法,工欲善其事,必先利其器,有了好的工具开发的时候心情好多了,自然效率也就提高了。

参考:http://blog.163.com/luckcq@yeah/blog/static/171747707201172223546805/

from:http://blog.163.com/lfsyhuangaigang@126/blog/static/774366702012913113253907/